Status Code: 401.failed to get organizations

After selecting Meshery provider and signing in to layer5 account, when I get redirected back to the application, several errors like this are popping up:


On checking the Networks tab I found that the request was made to http://localhost:9081/api/identity/orgs and was actually failing with 404 status code, with Status Code: 401.failed to get organizations mentioned in response body.

Please help me fix this.

I am also getting the same error on visiting user preferences page, which is appearing blank


Do you have multiple orgs? Try clicking the icon before “user preferences “ title, and try changing the orgs (if you have more than one).
// @Yash.Sharma .

On clicking the icon, no change happens in the page, and same error popup appears again.
I have only one organization listed in my layer5 account:


Here are the things I have done till now:

I am a newcomer willing to contribute, and don’t have a concrete idea about the features of the platform yet. Please guide me if I have missed any steps while setting up.

This is a bug in the Local provider. It’d be great to get a GitHub issue opened on the lack of support for Organizations in Local provider.


Also, the same issue with organisations also disrupts the proper rendering of some other pages like the “User Preferences” page. So, I had to proceed with the “None” provider for the playwright tests I had written recently.

1 Like