Issue while setting up Meshery UI

@sayantan1413 help plss

1 Like

Yes, @piyushsingariya I will catch up with @Fidal_Mathew in the slack to get more context on the issue and help him to solve it and will share the solution in this thread.

I’m hopeful that you will have the discussion here otherwise you’re circumventing the entire point of what we’ve been pulpit-pounding about. Others will miss out on the clarifying questions and troubleshooting process. They are not as likely to self-solve a similar challenge in the future. Don’t be stingy, please share with the rest of us. :slight_smile:

1 Like

Hey @Fidal_Mathew can you run mesheryctl system start once and then mesheryctl system stop. After than perform those steps you performed and then let’s see if this solves. Because I am quite sure the .meshery folder that is missing will be created by the start command.

Yes sure @Lee I will share the entire solution in this thread only :smiley:

Sure! I will try and let you know.

That would be great. Also, if you do not have Mesheryctl the CLI client for Meshery then run this one single command curl -L | PLATFORM=kubernetes bash - to perform all the steps starting from installing Mesheryctl to run Meshery in localhost.

The commands are not recognised.

I assume that you are on a windows machine seeing the path structure so do you have Docker Desktop? If not, install the Docker Desktop app and from the settings enable the Kubernetes. Then when you see both your Docker and Kubernetes are running then try to run the command once again. And if you face the same problem again then try this command once curl -L | PLATFORM=docker bash - . The previous command deploys Meshery in your Kubernetes cluster and this command deploys Meshery in Docker. And if you still face the same problem then you may consider installing through scoop and can refer to this guide. But remember it’s important to have Docker Desktop running. Though it is not necessary to use Docker Desktop only you can install Docker and configure Kubernetes manually but Docker Desktop is easy to configure.

I installed docker and enabled Kubernetes, but it didn’t work. I have installed scoop.
Should I run the scoop commands scoop bucket add mesheryctl scoop install mesheryctl )
in the command line or powershell?

I think it is better to run from the PowerShell.

This is the current state. What should I do next??

Yes, it will take some time to deploy Meshery in your kubernetes. Then you can access Meshery from localhost:9081. After you see that your Meshery is running successfully use mesheryctl system stop then perform the steps you performed earlier to run your Meshery locally. You will now have your .meshery folder.

Which flag to use??
My pc is using 100% CPU btw :joy:

@piyushsingariya do you know what might be causing this error? @Fidal_Mathew are you sure while you were running mesheryctl system stop you have the Docker Desktop running like both the Docker and Kubernetes were running.

Now, I stopped all the running environments in docker.
so, what should I do?


But, in task manager
This Is still running?

Okay, so it has stopped successfully now perform those steps that you have done earlier. And the CPU will be very high due to running this Docker Desktop.

Can I stop this, Vmmem?
I think this might be some virtual environment. Don’t know for sure.
I tried to stop it, but it can’t. It denied access.