When running layer5 in local development with make site Cmd Error 137

Getting error in Running make Site Cmd
make: *** [Makefile:26: site] Error 137

1 Like

I hate to be the bearer of bad news, but your system is running out of memory while trying to build the site. Try closing all other applications, killing all other unused processes, and building again.

I have Tried It but didn’t work. Going to try it again and I will notify you here
Thank you for your response.

What’s the hardware configuration of your machine?

System Information

  Time of this report: 4/6/2023, 17:38:18
         Machine name: LAPTOP-2PJL6LBN
           Machine Id: {33845D06-3408-4276-BAA3-065A4F5AA2AD}
     Operating System: Windows 11 Home Single Language 64-bit (10.0, Build 22621) (22621.ni_release.220506-1250)
             Language: English (Regional Setting: English)
  System Manufacturer: Acer
         System Model: Nitro AN515-43
                 BIOS: V1.03 (type: UEFI)
            Processor: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx   (8 CPUs), ~2.1GHz
               Memory: 8192MB RAM
  Available OS Memory: 6082MB RAM
            Page File: 10958MB used, 2548MB available
          Windows Dir: C:\WINDOWS
      DirectX Version: DirectX 12
  DX Setup Parameters: Not found
     User DPI Setting: 120 DPI (125 percent)
   System DPI Setting: 120 DPI (125 percent)
      DWM DPI Scaling: UnKnown
             Miracast: Available, with HDCP

Microsoft Graphics Hybrid: Supported
DirectX Database Version: 1.4.5
DxDiag Version: 10.00.22621.0001 64bit Unicode

Let’s see what your system’s free resources look like as you build the site…

do i need to hit make site cmd and then share details??

Also, be aware of this suggestion - Unable to run the code for Layer5 Repo - #5 by HetviSoni

Ok let me try this solution

Unable to run the code for Layer5 Repo - #5 by HetviSoni Tried this solution but again getting the same error

@Abhishek_Singh I would suggest you to run this command in a separate terminal outside vs-code
because sometimes due to heavy load of packages process gets killed

I tried it but still getting the same error

Hey @Abhishek_Singh , I’ve set up the Development environment in WSL and have faced no issues so far, this is a user-specific problem, as @Sudhanshu_Dasgupta, suggested removing all the background processes and running the make command through the terminal will help. WSL is very resource intensive, to be honest. You have to refer to online resources to solve this issue.

1 Like

I appreciate your help. I will try to find a solution and update you all. Thank you again for your assistance!

1 Like

hey @Karan but i not able to set up in wsl.

Hi !!
Has anyone found a solution to this?
I am getting same error. I am trying to run on WSL Ubuntu. I have tried all the solutions mentioned here.
I even tried running on window but there make setup took 2 hrs but still did not finish.

Your machine is running out of memory if you’re getting error code 137. Close all other applications on your machine, leaving only your IDE (or use Codespaces or Gitpod or a remote VM).

I tried closing all other applications; so will try other alternatives suggested

Gitpod worked!! Thanks Lee

1 Like