Unable to start Meshery

Hello everyone, I tried to set up meshery through this link, wherein I ran the docker desktop,
k3d cluster create in wsl, and then tried running mesheryctl system start. The first time I did that, it ran okay, and I tried installing some adapters (which seemed to work okay), but the second time, it is giving me these errors:

What can I do here? Thanks!

Also, I didn’t set up the KUBECONFIG environment variable. The first time, I tried setting it up, and it just wouldn’t start no matter what. So I tried starting with the local config, and it worked that time. Should I be setting up the KUBECONFIG variable using
export KUBECONFIG="$(k3d kubeconfig get 'k3s-default')"?
But when I try this, I get the below error when I try running kubectl config get-contexts:

If you’re running Docker Desktop, you can skip k3d and simply check the box for Kubernetes within Docker Desktop instead. This will simplify your networking setup.

I actually have both of them. I have enabled kubernetes within docker desktop, and I have also installed k3d. So if I understand what you said correctly, should I use the docker-desktop context in kubernetes while trying to run meshery, instead of trying to use the k3d cluster? Although that is what I was doing till now, that is, I was using docker-desktop as the context instead of the k3d cluster.

Would it help if I delete the manifest files in the .meshery/manifest directory @Lee ?

Sure, yes, you can delete that folder to start fresh or you can use mesheryctl system context and its subcommands to create and switch between different Meshery deployment contexts, @Samarth_Mayya.

@Lee I couldn’t get it to work either way :smiling_face_with_tear:. I am trying to run meshery on docker desktop with kubernetes enabled. Should the platform be docker or kubernetes for that? Because right now, in the screenshot of the config file below, the platform is being shown as kubernetes.

Should I try deleting the meshery namespace from the kubernetes namespaces?

Below is a snapshot of the command kubectl get apiservices:

The v1alpha1.metrics.smi-spec.io and v1alpha1.nsm.nginx.com services are both not available.

Great question. I’m curious about the state of your Meshery deployment. Will you paste (not screenshot) the output of the following command?

mesheryctl system status

Are you running Meshery in-cluster or out of cluster?

I’m not very sure actually. So I have enabled docker desktop, and the kubernetes context is docker-desktop. Does that mean it is in-cluster or out-of-cluster?
Also, I’m not able to start meshery itself. So the status command doesn’t really work

According to your screenshots, if you’re using either the local or the new_context context, then it means In-Cluster, because of the platform: kubernetes setting.

Right, so it should be in-cluster then. But the mesheryctl system status command doesn’t really output anything, except that meshery hasn’t been started

Thanks for huddling up on this, @Samarth_Mayya. It turned out the the particular release of Meshery that you were using was a botched GitHub workflow (a bad release). I’m pleased that we were able to get you up and running by updating to the latest release.


Thank you so much for your assistance @Lee :pray:

1 Like