Unable to setup Layer5 site locally

@Zaki_Shaikh @Saurabh100ni @Lee
I am setting up the layer5 site locally and following the steps mentioned in CONTRIBUTING.md of the issue and getting this error again instead I switched to Fedora from Windows WSL but same situation.
Also, do we need to run npm install -g gatsby-cli before the make site command?
Please me help.

hey @Saurabh_Singh Please make sure you have the following prerequisites installed on your operating system

If you have Forked the Layer5 repository and cloned your forked copy of the project properly and still getting the node_modules error then

  • Try deleting node modules (rm -rf node_modules) and setup again.

P.S. - Try these on WSL2.

1 Like

Thank you @abhijeetgauravm for helping me, as I was previously following the same steps but this time after removing the node module I did -

rm -rf node_modules


sudo dnf update

then → reboot →

sudo npm install -g gatsby-cli

Screenshot from 2023-10-07 10-07-58

and after that make setupmake site but still the same

And I am using Fedora 38 OS node version:- 18.18.0 & npm version:- 9.8.1 Gatsby CLI version:- 5.12.1

@Saurabh_Singh try using Git Bash or another terminal, It should work in that, as this terminal is taking apostrophe in the wrong way

  • I would recommend Clean setup through Git Bash.

@Saurabh100ni Thank you for your help. Well did once again as you told with a clean setup and this time through Gnome(Bash) shell instead of VS Code terminal but still the same

Hey @Saurabh_Singh as of error I can see you are somewhere using ' in directory Layer5_Repo'sname instead it should Layer5_Repos

Thank you @Yash.Sharma I’ll be changing the directory name to some other name and try again with a clean setup.

Thank You @Yash.Sharma @Saurabh100ni Finally I have successfully set up the Layer5 site locally on the same disk as the OS installation, using Node version 20.8.0 and npm version 10.1.0. It appears that the issue I previously encountered was due to compatibility between Node and npm versions, with the older npm version causing performance slowdown when a new version was available for installation.


That’s Awesome Saurabh :sunglasses: