Troubles in setting up Meshery UI development server

So I was trying to setup the UI development server by following the steps mentioned in this doc. I was successful in setting up the Meshery server in my local machine on port 9081 but couldn’t get the development server started on port 3000 . I tried running “make ui” but got some errors. Would love to get any assistance.

I’m tagging @Antonette.Caldwell, who might have some insight to offer as it relates to openssl. @shashank.singh please provide details of your environment (i.e. operating system).

Update- So the UI dev server is now up and running. I downgraded the node version from 18.0.0 to 16.0.0 and everything seems to work just fine now! (I am working on wsl 2)


Awesome, @shashank.singh. By the way, yesterday a fix came through in support of Node 18 from @Abhi. You might be able to revert back to Node 18. I’d be curious to know if 18 works for you now.

@Lee Apologies for the late reply. Unfortunately using Node 18 still results in the same error.

What operating system are you running? If Windows, try using WSL2.

I already use WSL 2 on my machine :sweat_smile:

Glad to see you figured out things yourself. Even though Node 18 may have been preferred but so far the node version doesn’t alter a thing, you are good to go. Well done!

Hi @shashank.singh Your problem was genuine a month ago. The node 17 and above had some breaking changes. Your solution of downgrading the node version to 16 worked because then we didn’t had support for node 18. But now on the latest code, you wont see such either with node >=18 or <18 .

Thanks for raising the issue.