Setting up docker dev environment in Meshery Docs!

How can I solve this?

@Chadha93 @Nikhil_Ladha can you help me please

Hi @Sambit.Sankalp! From what I can understand you are working on a Linux environment and already have Docker installed on your system.

Before running make docker, can you once check if Docker is up and running on your system? I have worked with Docker on Ubuntu and the docker.sock is a pretty common one.

Can you try running Docker daemon separately first? If you face the same issue, go through this StackOverFlow answer that helped me - linux - Cannot connect to the Docker daemon at unix:/var/run/docker.sock. Is the docker daemon running? - Stack Overflow

If Docker daemon runs without any issue, then run make docker

Hey @Sambit.Sankalp i have faced the same issue and this results because you dont have docker daemon running on your system.
Try installing by either
sudo apt install docker or…
Then you would have everything runnig,
Make sure you are running as a root user :+1:.

This will solve your problem hopefully.

HEy people,
Thank you for answering.

Like I have tried setting up locally without a docker environment, I think I could overcome the previous issue but again got into a new issue.

I am unable to figure out why docker is unable to detect why there is a version mismatch after modifying the version of ruby and bundler.

Can I get the solution for this please.