Not able to Upgrade the Meshery Server to latest version

Hello Members,
I am not able to upgrade the meshery to the latest version though i have subscribed to latest-stable channel . I tried deleting the whole namespace in k8s and tried redeploy it with msheryctl system start . It says downloading manifest files from but still when i launch my meshery ui it shows


Channel Subscription           Version
    Stable                     stable-v0.5.46

Newer version of Meshery available: v0.5.57

Can anyone help me out ?


@samirparhi-dev Could you go to your meshery-deployment.yaml file in .meshery/manifests and check this line?

Could you confirm it is layer5/meshery:stable-latest?

Could you also share the version of mesheryctl you are using by running mesheryctl version ?

You could update mesheryctl and try mesheryctl system channel switch to redeploy Meshery with the latest stable release.

Let me know if this does not work.

not working yet.

samirparhi@AsteriaMBP .meshery % mesheryctl system start
A new release of mesheryctl is available: v0.5.53 → v0.5.57
Check for instructions on how to update mesheryctl

version version is not a valid Meshery release
samirparhi@AsteriaMBP .meshery % 

@samirparhi-dev Can you update mesheryctl? You can run this command

curl -L | DEPLOY_MESHERY=false bash -

After you update mesheryctl, you can run the commands I mentioned above.

@samirparhi-dev Were you able to check this out?