Not able to add .kube config file

After starting meshery , i was not able to see kube config file so tried to import it,but after clicking import nothing changed, i have checked that my minikube cluster is already running

@Pranav.Patil, thank you for filing this issue. I’ll try to reproduce. In the meantime, will you grab the output from a mesheryctl system logs meshery or from kubectl logs -n meshery meshery-<xxxxxxxx> and attach here?

Hey @Lee apologies for very big delay…still getting the same issue
I am not able to send all logs attaching as docs link:

@revoly, this log line is occasionally seen on Meshery Server boot. Do you have notes on what this means? @Antonette.Caldwell, perhaps, we can get an error code assigned and notes persisted into the Error Code Reference in Meshery Docs.

meshery-meshery-1               | taskq: 2022/12/28 14:51:16 consumer_config.go:249: taskq: system does not have enough free resources

Oh, no. None of Meshery’s code should be using the GitHub APIs unauthenticated. Meshery and its adapters should be scraping where needed instead. @Ruturaj will you chase this one down?

meshery-meshery-traefik-mesh-1  | time="2022-12-28T14:51:17Z" level=error msg="[GithubWalker]: error occurred while processing github node API rate limit exceeded for (But here's the good news: Authenticated requests get a higher rate limit. Check out the documentation for more details.)"

This is from the memqueue library we use. I will investigate the reason and get back to it. Is there an open issue on this? If not, I should create one.

@Pranav.Patil here is the relevant log lines confirming that Meshery Server either can’t reach (network path) or can’t authenticate (certificate needed) either of the two contexts in your kubeconfig:

meshery-meshery-1               | time="2022-12-28T14:51:29Z" level=info msg="Generated context: btrfs-docker-k8s1.25.3\n"
meshery-meshery-1               | time="2022-12-28T14:51:29Z" level=warning msg="Skipping context: Reason => Get \"\": dial tcp connect: connection refused"
meshery-meshery-1               | time="2022-12-28T14:51:29Z" level=info msg="Generated context: minikube\n"
meshery-meshery-1               | time="2022-12-28T14:51:29Z" level=error msg="Kubernetes config is not initialized with Meshery" app=meshery code=2000 probable-cause="Kubernetes config is not accessible to meshery or not valid" severity=2 short-description="No valid kubernetes config found. Make sure to pass contextIDs in query parameters." suggested-remediation="Upload your kubernetes config via the settings dashboard. If uploaded, wait for a minute for it to get initialized"
meshery-meshery-1               | time="2022-12-28T14:51:29Z" level=warning msg="Skipping context: Reason => Get \"\": dial tcp connect: connection refused"

You will want to confirm that you can execute kubectl commands using those same contexts and that the Meshery Server container has network connectivity to your Kubernetes cluster’s API.

@Pranav.Patil do you see a notification in the UI confirming Meshery’s inability to connect to these different Kubernetes contexts? If it doesn’t itemize each context, then this is an ideal UX improvement to make.

If you haven’t already, sign up for Meshery Playground, which will let you get your hands on a portion of Meshery’s functionality while you work through your local setup issue.

[server] taskq library logs "not enough resource" error on Meshery boot up · Issue #6807 · meshery/meshery · GitHub Here is an open issue tracking this.

hey @Lee , No there was no notification in UI
yes I have signed up for meshery playground, will try out the functionality once I get the access

@Pranav.Patil let’s get you early access and have it turned on today.

@Lee just wanted to ask if I can do any troubleshooting to resolve this?

@Pranav.Patil Will you update this post with the steps that we took together and/or the resolution found?