Need better understanding of meshery and mesheryctl

Hi All,
I am Pravin newly joined layer5 community. I tried meshery for a week now but still i have some doubts. Also I need some guidance on how to configure meshery out of cluster setup with mesheryctl and better understanding of NATS.

Thanks,
Tatti Pravin

Hello @Pravin , welcome to the community.

To setup Meshery out-of-cluster you can use

mesheryctl system start -p docker

Though Meshery should automatically identify your cluster in most cases, in-case it doesn’t,

kubectl config view --minify --flatten > ~/config_kube.yaml use this command to minify your kubeconfig and upload it through Meshery-UI. You will get notified that k8s is now connected.

Reload Meshery-UI to ping meshery-adapters, and now you can “mesh-around

Incase you want to explore multiple platforms to deploy Meshery, you can check out this page- Supported Platforms | Meshery

This guide can help you with understanding a gist of each mesheryctl command- Command Reference | Meshery

1 Like

Thanks piyush,
Is there the command to set the kubeconfig file with mesheryctl instead of meshery UI?

1 Like

Yes, system config can assist you in this. But it support only few of the cluster platforms right now, such as minikube, eks, gke, aks

1 Like

Correct me if i am wrong here as i am new to this community. I thought eks, gke and aks need more details not as simple as UI way and if we select eks will this bring the meshery server and mesery operator in eks or meshery server will run locally and meshery operator runs in eks?.
My setup is i wanted to run meshery server and adpaters locally (docker or minikube or kind) and meshery operator (MesherySync and Broker) in OCI (Oracle cloud Instance). UI way of uploading the kubeconfig worked with some twist is there way to bring up this setup with mesheryctl without using meshery UI?

With “docker” platform meshery and adapters are deployed locally while rest of the resources can be deployed manually to remote cluster via Meshery UI, mesheryctl used to support this automatically before the helm based installation strategy was implemented.

Right now we don’t support OCI cluster configuration via mesheryctl, only workaround is the UI method.

It would be great if you could initiate an issue/discussion for OCI support.