My Predicament: Getting to Run Locally

For roughly 6 days, I have battled with running the site.
First, I forked and cloned the repo to my local machine. Everything after npm install was downhill.

Based on recommendations from Google, Stackoverflow and some Layer5 community members, I have:

  1. Confirmed node and npm are installed using node -v and npm -v commands respectively.
  2. Updated to latest version.
  3. Deleted node_modules dir and re-installed using npm install command.
  4. Edited PARALLEL_SOURCING flag in the gatsby-config.js file to false.
  5. Deleted the local repo and cloned again. Then npm install and npm start.
  6. Supercharged windows by using WSL. All attempts to use make commands landed me in error 127.
  7. To fix [makfile: 22] error 127, I ran sudo apt install cmake. (Still no luck)
  8. Finally, npm i puppeteer, followed by npm install, npm audit fix, and npm start…in that order.

The result? It is currently stuck on IMAGE_PROCESSING job.

In summary, SAVE ME! :sob: Thank you.