Mesheryctl system start throws an error

i’m using wsl kali, unable to figure out this error…

@Harsha mesheryctl is attempting to open your operating system’s default browser. You can ignore this error and open your browser manually. It would be great if you were to open an issue on this so that we’re sure to see it fixed.

@hexxdump, is there an option to disable this behavior? or an enhancement that we need to make to mesheryctl’s error handling?

sure @Lee ,but it’s saying that the site can’t be reached in localhost…

@Harsha, can you use mesheryctl system dashboard command to open the Meshery UI, once the mesheryctl system start ... command is run?

@Lee, Are you suggesting we should disable the call to dashboardCmd.RunE(nil, nil) in the system start flow and let users run the mesheryctl system dashboard manually ?

@hexxdump, thanks for clarifying. No, rather, I’ll propose that the existing behavior remain in-place (so that users continue to experience the convenience of having their browser opened), while the browser detection / error handling be enhanced to ensure this error is caught and instead either no message displayed or a simple message is displayed, conveying that Meshery is unable to open the browser and the user will need to do so manually.

Thanks for clarifying, @Lee! Will take a look at the error handling code.

Again the same error after running mesheryctl system dashboard, should i open an issue on this?

@hexxdump did you get any solution …?

@Harsha, yes, please do open an issue, if you would. Looks like bug.

I have opened the issue @Lee

where can find this issue “the same error after running mesheryctl system dashboard”, can you give some key words? and How this problem is now solved?

Hi @TwistzzLuffy, perhaps, you’ll have success with mesheryctl system dashboard --port-forward.

This is what I get when I type it in
截屏2023-10-15 下午5.25.03

I see.
Looks like pods haven’t come up yet.

Can you check the reason for this pending state? It could be that your k8s node is out of resources.
What output you get when you run:

kubectl describe po meshery-operator-xx-xxx
kubectl describe po meshery-xxx-xxx

You can update the pod’s hash based on the pod name in your cluster.

thanks, Is this due to the fact that I’ve laid out too many resources to learn k8s before?
the output:
Type Reason Age From Message

Warning FailedScheduling 5m44s (x112 over 3h13m) default-scheduler 0/2 nodes are available: 1 node(s) had taint { }, that the pod didn’t tolerate, 1 node(s) had taint { }, that the pod didn’t tolerate

Quite likely, yes. You can confirm my examining the amount of free memory on your machine.