Mesheryctl system start throws a "connection refused" error

When I run mesheryctl system start, I get the error:

connection refused. The Kubernetes cluster is not accessible. Please confirm that the cluster is running

Even tho I have docker desktop running and kubernetes enabled on it. See error below:

@Franklin.Ekoh thanks for raising this question. As a set of containers, Meshery supports deployment to either a Docker host or a Kubernetes cluster. Kubernetes is the default platform. mesheryctl is attempting to connect to a Kubernetes cluster, but unable to do so.

Model of deployment and configuration of deployment is configured in your meshconfig (~/.meshery/config.yaml). Your meshconfig can be configured either by editing it directly or through commands like mesheryctl system context, mesheryctl system channel, mesheryctl system reset, and so on. Using the mesheryctl system context command with the --platform flag, you can specify that docker be used as the deployment platform, not the default platform, which is Kubernetes.


New context using Docker as the platform and only loading the Linkerd adapter:

$ mesheryctl system context create --platform docker ekoh-docker -a meshery-linkerd
Added `ekoh-docker` context

See details of newly created context:

$ mesheryctl system context view ekoh-docker

Current Context: ekoh-docker

endpoint: http://localhost:9081
token: Default
token-location: auth.json
platform: docker
- meshery-linkerd
channel: stable
version: latest

Switching to use the new context:

$ mesheryctl system context switch ekoh-docker
switched to context 'ekoh-docker'

Listing available contexts and verifying current context:

mesheryctl system context list
Current context: ekoh-docker

Available contexts:

- ekoh-docker
- local


$ mesheryctl system context delete ekoh-docker
deleted context ekoh-docker
1 Like