Meshery docs navbar error

Hello guys,
I am working on the issue of navbar of meshery docs.
The redirecting links for another versions are not working on localhost for me.404 error
Though it appears to be working fine on website.
Can somebody please help me to resolve this?

In the documentation it is given that for contributing in meshery docs
we should run the following command
bundle exec jekyll serve --drafts --config _config_dev.yml
but in _config_dev.yml
exclude: [_site,, LICENSE,, vendor, Makefile, v0.6, v0.5, v0.4] is written and when I run the above command, I get the 404 error as mentioned above

but if i tried to run the following command
bundle exec jekyll serve --drafts --config _config.yml it is running fine. ig the difference is here in _config.yml and _config_dev.yml
exclude: [_site,, LICENSE,, vendor, Makefile]

please correct me If i am wrong and please guide me for the correct way.

Hey @Aniket.Ingle, have you attempted executing make docs? This command internally activates bundle exec jekyll serve --drafts --config _config_dev.yml.

yes I tried that as well and as it run bundle exec jekyll serve --drafts --config _config_dev.yml . this command internally that’s causing problem actually.
I have doubt like whether this command should be like bundle exec jekyll serve --drafts --config _config.yml. as the results are fine with this.

Ig it can be the issue because of this line exclude: [_site,, LICENSE,, vendor, Makefile, v0.6, v0.5, v0.4] in _config_dev.yml
If this is issue itself, I would like to fix it…

Hi @Aniket.Ingle, Thanks for bringing this up.
The past version of docs (i.e., v0.6, v0.5 and v0.4) are burried in time and seldom undergo changes. While they’re still crucial for live site, in dev environment we don’t expect modifications to be made in them. Not to mention, processing these huge past versions, will significantly add up to the overall build time resulting in even longer wait for recompiling and reflecting changes (currently takes about 15-20 seconds).

Hopefully this explains why we’ve exclude: [v0.6, v0.5, v0.4] in _config_dev.yml (config file for local build).

Ok thanks for clarifying :+1:.

1 Like