Make site command throwing error

aman@aman:~/Desktop/layer5$ make site
npm start

> Layer5@1.0.0 start
> npm run develop

> Layer5@1.0.0 develop
> env-cmd -f .env.development gatsby develop

sh: 1: env-cmd: not found
make: *** [Makefile:5: site] Error 127

this is the error showing while setting up the environment locally

Let’s me help you setup properly then. First I have few questions and suggestions as well.
What OS are you using, if it’s windows OS then you can run the npm start instead of make site. But since you already installed all dependencies with the make setup-libs, what you can do here is delete your node_modules first and run npm install and npm start sequentially. If you are using other OS like Linux or Mac, you can also delete your node_modules and run make setup-libs and then make site again. Be certain you have internet connection. Tell me if this solves your problems. Please send a follow up with screenshots.

there is no node_modules folder here after running make setup-libs

I’m using a Linux machine

Run npm install then. If it’s still doesn’t work, check that you have node installed with node -v. We could jump on a quick call to set you up.

after running npm install I have to delete node_modules ?

No.if it ran successfully, just run npm start after that

1 Like

previously it also ran but whenever I make some changes in the codebase it doesn’t get reflected in the localhost page

Include as much detail in the description of your issue as you can. What code changes are you making? If you have an error in your code, the page may not build and consequently not show.

If you can’t get it figured out here, be sure to join the Websites meeting on Mondays. Details here -

1 Like

okay we will discuss it there :airplane:

1 Like

Sounds great. But, please also don’t let my suggestion to join the meeting stop you from continuing troubleshooting here.

@Aman_Raza do you have gatsby cli installed?

sorry for the late reply I didn’t get any notification about this

yes it is installed


Hi Amana_Raza, Have your issues been solved?

No, it’s still there the site is running but the changes I make are not getting reflected on the browser.

Try to reload the browser when you make these changes. Also, some changes might require you to restart the server. You can add some random background-color CSS to be sure changes are not rendered. It might be that changes are rendered but not just working as you expect it to.

Ya I’ll try that
thank you

From your logs it’s quite clear that env-cmd is a package that is not installed, prolly its not your fault but the package.json file is missing this required dependency.

You can have it with npm i env-cmd, Probably someone else may be facing the same issue. If you can land a PR with this Fix that would be so kind of you.

@Aman_Raza Link to the dependency: env-cmd - npm