Make Server Error

make ui-setup & make ui-build command is working but

As I installed go1.20 version and then it’s shows me this error
$ make server
Dependency missing: go1.19. Ensure 'go1.19.x' is installed and available in your 'PATH'
INSTALLED_GO_VERSION: go version go1.20.5 windows/amd64
fatal: No names found, cannot describe anything.
cd server; cd cmd; go mod tidy; \
BUILD="" \
PORT=9081 \
DEBUG=true \
ADAPTER_URLS="localhost:10000 localhost:10001 localhost:10002 localhost:10004 localhost:10005 localhost:10006 localhost:10007 localhost:10009 localhost:10010 localhost:10012" \
APP_PATH="./apps.json" \
go run main.go error.go;
# runtime/cgo
cc1.exe: sorry, unimplemented: 64-bit mode not compiled in
make: *** [server] Error 1
fix this error

And after that, I removed the version and installed the go1.19 version and now I get this.

It’s your system’s architecture issue.
When running mingw-64-install.exe , you have to choose the x86_64 architecture on the settings screen while installing Mingw.

Alternatively, you can use WSL2 for more smoother development experience on windows.

Hey Gaurav, I am already working from WSL2 but still getting the same error, can you please help me out here?

Sure, @Samyak.Shah. Please share some logs or screenshots of the error you faced in WSL.

Thanks a lot :smile:
Here are some of my logs and errors on WSL

Incase if required.

The screenshot of your build shows a successful build. Open up Meshery UI at http://localhost:9081.


I want to know about this line. Why it’s showing if the server is running?
fatal: No names found, cannot describe anything.

Regarding that specific message, it seems as though this system is missing git-describe , causing a portion of the build process to fail. This portion of the build process determines the latest released version number of the Meshery project.

@Vaibhav.Maurya Did the above mentioned solutions worked for you?


Sorry to update, Yes :saluting_face: this works for me.

Download MinGW x86_x64 architecture. Here is the download link.


  • While scrolling down, download the latest version of x86_64-win32-seh.

  • Extract zip file.

  • Paste/move the folder to C:\ drive.

  • Copy directory C:\mingw64\bin.

  • Now paste this to Environment Variable Path.

Note: I am using windows terminal.

1 Like

Good to know, it worked for you :slight_smile: and thank you for articulating the steps. @Vaibhav.Maurya
Thanks @Chadha93.

1 Like

Thanks buddy been struggling for more than 2 hours with this error been through stack over flow , github issues nothing worked .
But this worked for me .