Layer5 setup error

Layer5 website setup taking more time than expected and not settings up as well.
It’s not going any further

What are your machine’s specs?

Host Name: LAPTOP-RG0S43HE
OS Name: Windows 11

@GAUTAM_RAI what you were doing exactly, I mean which make command you were executing?

I am using make site command

@Zaki_Shaikh @Lee Today server started but took a lot of time and multiple restarts. I didn’t do anything different :slightly_smiling_face: :melting_face:

@GAUTAM_RAI , Please switch to wsl ( Windows Subsystem for Linux ) for better results.
Follow the contributing guidelines.

1 Like

Even I have that on mind will do it this weekend surely

@GAUTAM_RAI let us know about how it goes and your experience using wsl instead of windows.

Yeah sure. I will share the experience.

I have added WSLto my system and its working perfectly will start working on the issue :smiley: :smiley:

:clap: :clap:
Thank you folks!

I am facing this same issue. Added WSL to my system. Still no good

@khushalsonawat what error you’re getting?

Slack - An ss of the error. I asked in slack, they said it is a timeout error. But even after using wsl i get timeout error, then how do i run this

@Ghat0tkach has given you a solution on Slack, did you try that?

The easy alternative would be to use

1 Like


There’s high chance that running out of memory is what crashes the build!. you can check how much total memory is allocated currently to wsl by running free -h command. ( if it’s around 3gb, let’s increase to 6): here’s what you can try doing:

  1. run cmd as admin
  2. run wsl --shutdown command. ( done can close cmd)
  3. Now let’s configure wsl memory ( the maximum system memory that the wsl can make use of during processes like running docker images, kubernetes, or heavy build processes like the image processing jobs here) :

in C:\Users\<your_user_name>directory, create a file named . wslconfig and put these settings in it:

[wsl2] memory=6GB

once done, restart wsl and can use free -h command to see that the total memory now is somewhat around 6gb.
Try running the build server again, and if it again crashes

  • please restart your system, pull latest from the upstream and see if it solves the issue.
  • also try closing all other applications, except for your terminal while running this command and see if that helps get you past it.
1 Like

I got a solution to use gitpod. But that is limited to some 50 hours per month

Will try this implementing this one