Issues regarding instructions to set up meshery docs locally in Linux

While trying to set up the meshery docs locally referencing this i ran into some issues.

Issue 1:
While installing the prerequisites “libgdbm3” present in this command sudo apt-get install autoconf bison build-essential libssl-dev libyaml-dev libreadline6-dev zlib1g-dev libncurses5-dev libffi-dev libgdbm3 libgdbm-dev was generating this message.
E: Unable to locate package libgdbm3

This issue got fixed while I installed the “libgdbm6” which is higher version than “libgdbm3”. My ubuntu version is 23.04

Issue 2:
The install command was not found as The install command is not embedded into rbenv, it comes from the ruby-build plugin. Thus, it was generating error.

The issue got fixed by installing ruby-build using this command git clone "$(rbenv root)"/plugins/ruby-build

Issue 3:
Getting error while running rbenv install 2.7.5 or rbenv install 3.2.2

But I guess my system has ruby installed don’t know how as ruby -v and which ruby command is generating this.


Can someone tell me if my installation is successful or something wrong happend?

@Debjyoti_Sen please share what error you got if you have, based on information you’ve provided it seems that ruby is downloaded by snap tool see this directory: /snap/bin/ not by rbenv.

It is generating this error while running “rbenv install 2.7.5”

Heya @Debjyoti_Sen, We have recently migrated to ruby 3.2.2, you can install using rbenv install 3.2.2 and then rbenv global 3.2.2 and rbenv local 3.2.2

You can also give rvm a shot.

Generating same issue

I tried this command from one of your reply rvm install 3.2.2 --enable-shared --with-openssl-dir=/usr/local/opt/openssl@1.1 , but it is generating this

@Debjyoti_Sen if rvm isn’t installed on your system them download it see its officail documentation.

Oh I already installed rvm and installed ruby. Sorry I forgot to put the update here.
Can you confirm is the ruby installation successful?


While the right version of Ruby might be installed (via rvm), it may well be that the openssl portion of the installation isn’t quite configured correctly (that perhaps, your openssl installation resides in a different location in your filesystem).

The and other Jekyll sites maintained here, don’t necessarily strictly require use of 3.2.2. So, if you can’t get 3.2.2 going with your openssl installation, you can try removing the specification of 3.2.2 from the Gemfile and using different version of Ruby/Bundler - just don’t commit those changes when you PR.