I tried Cloning the repo since yesterday, and I keep getting errors

Hi @Princessayomide53, Thanks for opening the Ticket.

The error is usually caused by network-related problems, including lost connections, network timeouts, firewalls, VPN clients, or anti-virus.

Please try temporarily disabling your firewall and antivirus software before attempting the clone again.

Okay, thank you I will do just that

@Princessayomide53 one trick in this regard is to use the --depth=1 flag when you run git clone .... --depth=1, which changes git’s behavior to only download the latest version of the files, sparing the rest of your bandwidth and disk space from all versions of the files, which in some cases are quite large.

Still getting errors, from cloning
I disabled my firewall

Gotcha. Internet / network connection seems to be having some difficultly. You can also try deleting your partial clone and starting from scratch with a fresh clone.

Tried it out multiple times, Finally got cloned on my system… I have the cloned repo now
Thank youuuuuuuuuu so much
Please how do I run it
I did npm I and try to run it’s not running

Contributing docs here - Contributing | Meshery

You’re going to want to use WSL2 or macOS or Linux.

Thank you so much Sir
I will do just that
I couldn’t set it up I was down with fever
Buh I feel better now
I will follow the instructions and setup today
If I encounter any problem, I will drop some messages here
Thank you

I have issues installing Docker on my system

@Princessayomide53 I can see your os is windows 10, just ensure running the Docker installer as administrator.