I am facing error while setting up the project locally

when i am running the command make site it showing
sh: 1: env-cmd: not found
make: *** [Makefile:26: site] Error 127
Screenshot from 2023-07-21 22-59-59

Hey there , This error is due to the gatsby cli missing.
install it using
npm install -g gatsby-cli

Still having the same issue

once you have installed gatsby
please check version of gatsby using gatsby -v
the gatsby cli and gatsby version will be displayed

use make setup and make site

I have alreay done that it shows Gatsby CLI Version 5.11.0 and on running make site it shows some errors and then on running make site it shows that screenshot i have shared

I ran into same problem , Ill suggest using the following commands in order
make clean
npm install -g gatsby-cli
make setup
make site
I wonder if the same works for you as well

on running the command make clean this is coming

I got the issue , you have installed gatsby after make setup
as result its not recognizing gatsby .
use this instead npm cache clean --force
and then use the commands in order
npm install -g gatsby-cli
make setup
make site

I did exactly what you said, still the same issue… i ran the commands in order its still showing some errors in make setup command… it was also showing some issues on installing gatsby but then i gave su acess and it ran okay … but still same issue when running make site

Can you please send me ss of errors which were displayed after using make setup?

These are the errors

@Ghat0tkach can you please review these errors.

what is your node js version?

1 Like

node version v18.16.1

btw just to be clear did you used
git clone --depth=1 https://github.com/<your-username>/layer5.git to clone the repo?

@Nakul_B , It’s been a long time since you are facing this issue .
I’ll advise you to use Gitpod to run website for the time being while you discover the possible fix of this situation.
Let doesnt make this issue stop you from contributing :raised_hands:

1 Like