I am always facing the issue - Build failed because of webpack errors, Build failed because of webpack errors

I am always facing the following issue showing in the screenshot even if I am not running any other process just a single vscode with Meshery. Previously sometimes ran successfully while facing the same error but now not able to go further.
Is my PC not capable of running Meshery properly?
|Processor|AMD Ryzen 5 5500U with Radeon Graphics 2.10 GHz|
|Installed RAM|8.00 GB (7.33 GB usable)|
|System type|64-bit operating system, x64-based processor|

why always happening such an issue?

Hey @csengineer23, As Next.js uses Webpack to build your project. Webpack is known to have issues with handling large numbers of files. On looking at your logs it seems you have too many open files, which is preventing the build process from completing. either you can reduce the number of open files or you can try increasing the file descriptor limit if the maximum number of files that a process can open simultaneously using this cmd ulimit -n 4096

1 Like

Sir, I tried the solution as you said but not working. I used commands in both bash and WSL but still got the same issue. I am still finding solutions .?