How to setup meshery local development environment

I have been trying to setup meshery on my local machine to see the server error logs to fix a issue, but I’m unable to do that, i even searched for the docs, but that didn’t worked out for me.

I just want to know step by step command to run meshery(both ui and server) on my local machine, because i think, I’m messing up things there!

Hello Adarsh!
Can you please provide us with a small description of what you have tried and what outcome it produced?
It will allow everyone to get a better idea of what’s causing you problems and help you in a more efficient manner. :smile:

Which specific step of these contributing guides are you not able to execute?

I was getting issue in making the ui, but now everything is resolved. Thank you so much for helping :slight_smile:


That’s awesome, @Adarsh_Jaiswal you were able to get ui running :sunglasses:
For community members, do you mind sharing what was the issue and how did you resolve it,
so that they can refer to your notes, just in case ?

So, I was building the Ui first using make ui-build and followed by make ui-setup and additionally i was using this command as well make ui. and then i was starting the server. After doing that i was trying to use meshery provider as none, and that causing me errors while fetching design components!

Makes sense. Thanks for sharing, @Adarsh_Jaiswal. In following with the order outlined in the contributing guides, you’ll want to start with make ui-setup. :+1: