Hey Everyone I am facing issues in installing gatsby in the system

  • First i have installed gatsby globally using npm install -g gatsby-cli.
  • but after running gatsby --version , it gives :
line 1: This: command not found
  • I think it is not installed that’s why i am getting this.

I am assuming that you are trying to set up your dev environment.

Follow the directions for “Setting up your Development environment”
step by step.

It should be straight forward.

If you continue to have problems, then you can describe your environment for more assistance.

but i want to setup for local development environment , it says you should have gatsby in your system but i tried to install gatsby but it didn’t worked.

It got stuck here.

@Aarav.Shukla what’s the processing power of your machine (CPU and memory)? Try closing all other applications, except for your terminal while running this command and see if that helps get you past it.

Yeah i am trying !!!

it again got stuck here

My system configurations are:

  • AMD Ryzen 5 3500u
  • 8GB RAM

@Aarav.Shukla other potential helpful things to try:

rm -rf node_modules
rm -rf .cache
make setup
make site
1 Like

do i need to install gatsby in my machine??

Aarav, I think a prior node.js initialization might be holding you up, if you remove the node_modules, and .cache, you should be able to run

make setup
make site

That should handle the Gatsby configuration. What I am saying is that the prior independent Gatsby install likely has conflicting dependencies with the project.

Now i am getting this when i tried this on ubuntu .

@Colby_Stoker @Chadha93 any suggestions here ?

Confirm that husky is installed.

Did you run make setup ? That should have resolved all the dependencies for building the site, including husky. You should not have to independently install the dependencies, it is the purpose of Node Package Manager and husky is a dependency in package.json

Go into the Layer5 directory and run make setup respond with any errors.