Getting problem while running make server command to setup meshery-ui

I ran make ui-setup and make ui-build commands
but while running make server command
im getting following output


what should i do next?

This error only shows up in powershell, So instead of using powershell use git bash or wsl2

Good question. Be sure to confirm that you have go1.17.8 installed on your system. See Managing Go installations - The Go Programming Language for instructions and that go1.17.8 is available in your chosen shell (whatever that might be). Like @Yash_Kamboj says, you’ll find that WSL2 and bash are a more natural fit for the project.

there is latest version of go on my system. I tried it with bash also and still getting same output.

Do other make commands work ?

Let’s get specific. Having go available on your system isn’t quite what I said. Rather, very specifically, I’m saying have go1.17.8 installed and available in your $PATH.

actually after running make ui-setup command,
I got
cd ui; npm i; cd …
The system cannot find the path specified.
make: *** [Makefile:147: ui-setup] Error 1
this output so i ran the commands as mentioned in makefile
those were
cd ui; npm i; cd …
cd provider-ui; npm i; cd …
same in the case of make ui-build

it was go1.18.4, but now I tried it with go1.17.8 and same output

Sounds like you don’t have go1.17.8 in your $PATH. What output do you get from which go1.17.8? or from just executing go1.17.8? If either report that the file is missing… there’s your problem.

@Aniket.Ingle I just got struck with an idea… If you tried on bash, have you ensured you included your Golang path in the $PATH variable of the ~/.bashrc file? If that’s missing then you need to add that export $PATH=... line in the .bashrc and reload your shell using source ~/.bashrc

Maybe if we reproduce the error we might know where we exactly went wrong… I’ll also test this in the bash in meantime

Ok hold on… instead of go run main.go it’s made to run only on go1.17.8 eg: go1.17.8 run main.go. Reverting to go instead of go1.17.8 will run the make server command on any version. But that’s not advisable mostly…

So, do the following and let me know if worked…

  • Assuming you have golang installed in the bash, run the following command to install go install golang.org/dl/go1.17.8@latest
  • Then, run go1.17.8 download
  • Finally, check running go1.17.8 version, you should have got the correct version running up

NOTE: This is for make server command!

1 Like

i’ve a different solution to this issue but it worked for me if you have the latest golang version installed on your system then you can comment out the line “GOVERSION = 1.17.8” inside meshery/install/Makefile.core.mk , after commenting out you can start your server with make server command

Heyy @Aniket.Ingle ,The issue is actually with make, not that it isn’t installed, but with the one that has been installed. The installed make isn’t able to clearly execute ‘cd’ or few other Linux commands here, hence the error ‘cannot find the path specified’. You might’ve noticed how these Linux commands are working without it being run using make. I’m attaching a blog post here on the issue, and how it got solved for me. Hope it helps you as well. How to install 'make' on Windows Machine .

1 Like

That also works but we’re trying to make it more organised rather than running different versions while running the script to ensure some dependencies don’t get mixed with other versions. You know what I’m inferring to. Other than that, this method also works

Ah, the GCC x64 version :slightly_smiling_face: thanks for sharing @Zain-Muiz

thank you so much @Zain-Muiz

Hi @Aniket.Ingle have you had any luck with this??

If not, you can actually edit the environmental variable in the install/makefile.core.mk and temporary remove the GOVERSION environmental variable and then run the make command again. Remember to include it back before pushing any changes. This is a bit hacky but will do the trick for you to start contributing.