Getting error setting up environment for docs

I am getting the following error while running bundle install:

Also i was getting another problem while executing : make site ,
for this error was : make: *** No rule to make target ‘site’. Stop.

@Simardeep_Singh_Mudhar you’ll want to ensure that you have openssl installed on your system, too.

I tried installing openssl on my arch system, but now I am facing a new error → __rvm_make install :

try opening meshery using windows , install the ruby dev kit , install bundler and jekyll and then do the prescribed commands
bundle install
make site
if you ran into some error use
"bundle exec Jekyll serve --drafts " command

1 Like

If you see openssl in your install logs, you might want to try using a couple of flags while installing the specific version of Ruby; e.g.:

rvm install 3.2.2 --enable-shared --with-openssl-dir=/usr/local/opt/openssl@1.1