Facing an error in setting up meshery locally


I have met the prerequisites but still couldn’t start setting up meshery locally

Can you make sure that a Kubernetes cluster is up and running, if you are using the docker desktop, just enable kubernetes in the settings .

After that, If can run the mesheryctl system start ,

Do lemme if you again ran into error

Hi @harkiratsm , I enabled the kubernetes from the settings of docker desktop and ran the command but Facing the same error again!!

This seems to be a permission error. Have you tried running this with the sudo command to see if this resolves the issues.

I have tried using sudo command but facing this error and I am new to kubernetes. So, Can you please let me know what I have to do?


Thanks!!

@gopi.vaibhav you will need to either have a running Kubernetes cluster with access available via your kubeconfig or you can forego having Meshery interact with Kubernetes by switching to a Docker-only deployment like so:

mesheryctl system context create docker -p docker
mesheryctl system context switch docker
1 Like

I see now that you do have a Kubernetes cluster available. That’s great.

I resolved this error by removing .meshery folder from home/< username > and mesheryctl from /usr/local/bin
Thank you !!

Thanks @Lee :smiley:
Heading towards my contribution in the layer5 community from now!!

1 Like

Flushing your ~/.meshery folder so that mesheryctl will reinitialize it upon next invocation of a mesheryctl command makes sense. Good troubleshooting, @gopi.vaibhav :+1:

Unless you have another copy of mesheryctl on your system, I suspect you’re going to want to restore or reinstall mesheryctl.

1 Like