Error while trying to run Meshery locally

Command used: mesheryctl system start

Error: failed to download /Users/sreya/.meshery/meshery.yaml file from

Hey @Sreya.Gadepally, happy holiday. I will get you help. You can do well to include screenshots of the errors you get // @alphaX86

Hey! Apologies for the delay. Here is the screenshot of the error that I got when I tried running Meshery for the first time after installing it.

I remember installing it previously. But, I tried installing again anyways and this is the error I got

I watched a video on ‘Setting Up Meshery’ on Meshery’s official Youtube channel. I realised that I don’t have minikube installed. So, I went ahead and installed it using brew. Then I ran the command, ‘minikube start’ and it ran successfully. Then i upgraded mesheryctl using brew. Then I ran the following command:

This opened a new tab in my browser. But it gave an error saying that the ‘localhost refused to connect’

Update: I was able to run Meshery and solve the above problem for which the solution is given here Localhost connection refused to meshery

In summary, the two resources that helped me: