Error while setting up docs locally

cc: @vishalvivekm @Sudhanshu_Dasgupta

Hi @Ripul.Handoo , I’ll assume you’re getting this on running make docs.
Please pull the latest from the upstream and then try. working fine on my machine.

I tried both git pull upstream master and git remote update. Still getting the same error.

Try following commands

  • gem update --system
  • gem install escape_utils
  • gem update escape_utils

I have had the same issue for over ~7 days (consistently):

  • re-cloned the repo a few times thinking it was a cloning issue (something not downloaded properly)
  • cd docs
  • make docs

  • adding the missing gems one after the other as the error messages came, but they kept coming.


  • WSL2 Ubuntu 22.04.3 LTS
  • Windows 11

Day 8: What worked for me

  • clone the fork of your meshery repo (again if you have to)
  • cd meshery
  • cd docs (there was an automatic output to the terminal stating that ruby 3.2.2 was not installed)
  • installed ruby 3.2.2
  • ran bundle exec jekyll serve


These are a lot of commands to run individually so I used ChatGPT (for efficiency) to create sudo gem install [command] -v 'v.v.v' for each gem, and ran it all at once

  • depending on your bandwidth speed this can take some time to complete
  • after all gems were installed, I ran bundle exec jekyll serve again, and the docs were successfully deployed on local server.


@Ripul.Handoo have you successfully built docs right now?