Error while running mesheryctl system login command

As you can see here I’m getting this error whenever I try to run mesheryctl system login command. Meshery is running on my localhost but it is not able to reach it any help. Also tried doing system checks too and everything’s good.


I found someone with the same error but was using chromium and they did this but doing this for google chrome didn’t give me any results


@hexxdump might have some insight to share here, @ShivangShandilya

1 Like

@ShivangShandilya were you able to find a fix for this issue?

Nope, still facing the same issue. Would like to have your insight on this issue

@ShivangShandilya, as per the above screenshot, xdg-open is not installed on your system, have you tried installing xdg-open and check if the system login works as expected?

Great to have you back on discuss, maintainer @hexxdump :sunglasses:

No no, I checked I have xdg-open and when I opened it using vim, it looked exactly like this:

Just instead of [ x"$BROWSER" = x"chromium" ] I don’t have chromium with x this is because for the system to automatically find the current browser.

I even tried to add Google Chrome with x but couldn’t get it working…

Have you tried setting a default browser for linux