Cluster Unreachable in-cluster install of Meshery on KinD

I tried to follow the instructions to setup meshery on my kind cluster for development.

Meshery is being deployed on the control plane of the cluster.
I installed the cluster via mesheryctl. I get meshery up and running. All services, pods etc. are up and running.
I am accessing meshery UI via a port-forward to>meshery:9081

But Meshery UI is unable to access the cluster

This is the output of mesheryctl system status

meshery         	1/1  	Running	0       	17m1s 	
meshery-broker  	2/2  	Running	0       	16m49s	
meshery-operator	2/2  	Running	0       	16m57s	

Meshery endpoint is http://localhost:32565

Ignore the endpoint mesheryctl does not expose the correct endpoints on the cluster I need to use separate port-forward to get this working

This is the output of dashboard

I cannot deploy any meshes because I am unable to access the clusters.

I tried pinging the cluster in the UI but I am always greeted with this message
Not able to ping kubernetes: kubernetes-admin@kubernetes

Steps to reproduce

  1. Make sure you have a KinD cluster (Make sure you setup a loadbalancer such as MetalLB)
  2. Set the kubeconfig context to point to the correct cluster
  3. deploy meshery via mesheryctl mesheryctl system start
  4. The Meshery UI is unreachable via endpoint reported by mesheryctl. So setup your own port forwarding kubectl port-forward svc/meshery 9081:9081 --namespace meshery
  5. Access the dashboard at http://localhost:9081

Try disconnecting that cluster. It’s possible that this is the Playground cluster, not your local cluster.

Thanks for the help but I am unable to access the cluster inside which meshery is installed am I doing something wrong ?

As you follow these steps, do point out where these don’t work for you, so that they can be improved - Minikube | Meshery

On Accessing the dashboard. There are no clusters detected other than the playground cluster

Thus I am unable to deploy any service meshes via the UI when I click on “Install Service Mesh”

I have enabled meshery-linkerd and meshery-istio adapters

In connections dashboard

I am unable to list my cluster.

More Context
I am trying to deploy on the same cluster where I want to manage the Service Meshes.
I am quite new to Service Meshes. So, I may be setting up Meshery incorrectly.

@Harsh.Mishra you’ll need to confirm the steps in the link that I provided above and their output/outcome.