After building Meshery locally, I'm being redirected to a page asking me to upgrade

I’m trying to build the Meshery project locally, I followed the instructions here (Contributing to Meshery Server | Meshery). The build succeded, but after visiting localhost:9081 and choosing Meshery as the provider and signing in with Github, I get a message saying Meshery Deployment Incompatible UPGRADE MESHERY. Can someone help with this?

@deepto98, let’s get you past this. Will itemize the exact commands that you ran to create this build?

@Lee Thank you, yes, sure. I ran:

make ui-setup
make ui-build
make server

Then I waited for the build to complete. Upon completion, I opened 9081. First it prompted me to sign in, redirected to the dashboard on the layer5 website. Upon visiting 9081 again, I saw session not found, and then was redirected to the Upgrade Meshery page, which I’ve attached a screenshot of.

1 Like

@deepto98 I encourage you to join the weekly Meshery Dev meeting and let’s troubleshoot live. Other contributors don’t report this behavior. There’s likely a small item that is getting in your way and that is specific to your system. Try using a private browsing window when you open http://localhost:9081

Hi… I am getting the above same error and I also followed the same command and contribution guide.
what should i do?

Resync your fork. Instructions here.


  • Go to your meshery folder in your local system where you’ve cloned it.


  • git remote add upstream

  • git fetch upstream

  • Restart the meshery server

  • git pull upstream master to pull

Thank you so much, sir.

Thank you so much, @Mohith_Gadireddy .