Service Mesh Adapters are not found on running meshery server locally

While we run meshery services under minikube, all the service mesh adapters are detected properly.
like this

But when I run the local meshery server by make run-fast. I get adapters from mesherylocal.layer5.io which is not what I desired.

How can I set the service mesh adapters successfully.
p.s. I am using the same kubeconfig for connecting both server, I hope it is not the root of such problem.

@Abhi we can do two things here:

  1. Add mesherylocal.layer5.io in your /etc/hosts (for UNIX based systems, similar construct is available in Windows too I think)
  2. Replace mesherylocal.layer5.io in your Makefile to localhost. We no longer use or require mesherylocal.layer5.io it is just a legacy item unfortunately.

Also, would you mind opening an issue in meshery repository which suggests the changes to makefile as mentioned in option 2 above?

1 Like

Additionally as suggested by @utkarsh-pro
We also have to start adapter seperately in a container to establish connection. Since make run-fast only starts meshery server and not adapters.

You can get your adapters from here : Docker Hub

For instance, to start istio-adapter:
run:

docker run --rm -it --network host layer5/meshery-istio:edge-latest