Meshery server not running

I just completed setting up my meshery server on pop os which ran just fine with following output

codralxx@pop-os:~/Documents/Dev/meshery$ make server
cd cmd; go mod tidy;
BUILD=“v0.6.0-rc.5r”
PROVIDER_BASE_URLS=“https://meshery.layer5.io
PORT=9081
DEBUG=true
ADAPTER_URLS=“localhost:10000 localhost:10001 localhost:10002 localhost:10004 localhost:10005 localhost:10006 localhost:10007 localhost:10008 localhost:10009 localhost:10010 localhost:10012”
APP_PATH="…/install/apps.json"
go run main.go;
INFO[0000] Registered Meshery local Capabilities
INFO[0000] Meshery server current channel: Not Set
INFO[0000] Using ‘/home/codralxx/.meshery/config’ to store user data
INFO[0000] Using ‘/home/codralxx/.kube’ as the folder to look for kubeconfig file
INFO[0000] Log level: debug
INFO[2022-05-21T17:28:24+05:30] extracting Filters from /home/codralxx/.meshery/content/filters/binaries app=meshery
INFO[2022-05-21T17:28:24+05:30] starting to seed Filter app=meshery
INFO[2022-05-21T17:28:24+05:30] saving Filter- http_auth_bg.wasm app=meshery
INFO[2022-05-21T17:28:24+05:30] saving Filter- jwt_filter_bg.wasm app=meshery
INFO[2022-05-21T17:28:24+05:30] saving Filter- metrics_collector_bg.wasm app=meshery
INFO[2022-05-21T17:28:24+05:30] saving Filter- singleton_http_call_bg.wasm app=meshery
INFO[2022-05-21T17:28:24+05:30] saving Filter- singleton_queue_bg.wasm app=meshery
INFO[2022-05-21T17:28:24+05:30] saving Filter- tcp_metrics_bg.wasm app=meshery
INFO[2022-05-21T17:28:24+05:30] saving Filter- tcp_packet_parse_bg.wasm app=meshery
INFO[2022-05-21T17:28:26+05:30] extracting Patterns from /home/codralxx/.meshery/content/patterns app=meshery
INFO[2022-05-21T17:28:26+05:30] starting to seed Pattern app=meshery
INFO[2022-05-21T17:28:26+05:30] saving Pattern- IstioFilterPattern.yaml app=meshery
INFO[2022-05-21T17:28:26+05:30] saving Pattern- bookInfoNoK8sPattern.yaml app=meshery
INFO[2022-05-21T17:28:26+05:30] saving Pattern- bookInfoPattern.yaml app=meshery
INFO[2022-05-21T17:28:26+05:30] saving Pattern- istioinstall.yaml app=meshery
INFO[2022-05-21T17:28:26+05:30] extracting Applications from /home/codralxx/.meshery/content/applications app=meshery
INFO[2022-05-21T17:28:26+05:30] starting to seed Application app=meshery
INFO[2022-05-21T17:28:26+05:30] saving Application- bookinfo.yaml app=meshery
INFO[2022-05-21T17:28:26+05:30] saving Application- emojivoto.yaml app=meshery
INFO[2022-05-21T17:28:26+05:30] saving Application- httpbin.yaml app=meshery
INFO[2022-05-21T17:28:26+05:30] saving Application- imagehub.yaml app=meshery
INFO[0008] Starting Server listening on :9081

However, when i tried to access meshery at my local host http://localhost:9081 it gave 404 page not found.

Be sure to have also built Meshery UI. Quick guide:

make ui-setup; make ui-build

Thanks! It worked and ran.

1 Like

Excellent! You’re off to the races, @Alok_Jha. :slight_smile:

Hi, I am able to successfully run make ui-setup and make ui-build But when I run make server I am getting the following error while trying to run the Meshery server on 9081. I think it’s something to do with my Go installation, but I’ve installed Go, and it is available on PATH.

But I am able to access Meshery UI on port 3000 with make ui-setup-libs, make build-ui and make run-ui-dev commands.
I am Ubuntu 22.04

@Santosh1176 great question. Be sure to have go1.17.8 installed on your system. See Managing Go installations - The Go Programming Language for instructions.

1 Like

@Lee Thanks for the reply and helping me out. I’ll try this and get back.

Thank you!
This worked out smoothly. Now, let me see how can I contribute to the project.