Getting ECONNRESET after running UI dev server

Here’s the complete error

event - compiled successfully
throw er; // Unhandled 'error' event
^ Error: read ECONNRESET
at TCP.onStreamRead (node:internal/stream_base_commons:217:20)
Emitted 'error' event on Socket instance at:
at Socket.onerror (node:internal/streams/readable:773:14)
at Socket.emit (node:events:527:28)
at emitErrorNT (node:internal/streams/destroy:157:8)
at emitErrorCloseNT (node:internal/streams/destroy:122:3)
at processTicksAndRejections (node:internal/process/task_queues:83:21) {
errno: -54,
syscall: 'read'

I am using M1 Air and Docker extension meshery. Earlier everything was working fine but recently got this error.

@Udit.Takkar can you try deleting the thenode_modulesand then go through the installation again?

Tell me if this solves the problem.

ok will try this fix :+1: now

btw this did not work. still trying to find out what’s wrong

tried running make server instead of using docker extension and now it is working fine.

1 Like

Please describe the steps that you have followed (including all the commands).

It’s working fine now. i tried logging out at http://localhost:9081/http://localhost:9081/ and logging in again and no error was thrown now.

1 Like