Error running Mesheryctl on Windows

Hello folks , just have some issues here, i have error in running mesheryctl on my windows machine this is the error message it gives below

": could not install meshery server: looks like “Meshery Chart | Meshery” is not a valid chart repository or cannot be reached: Get “https://meshery.io/charts/index.yaml”: read tcp 192.168.75.115:52488->185.199.109.153:443: wsarecv: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

1 Like

It would be surprising if this was a Windows-specific issue. It seems that the network connection between your machine and the Meshery Helm chart repo on GitHub timed out. I wonder what results you would have if you were to try again. Are you able to access https://meshery.io/charts/index.yaml from your browser (or better yet, from curl or wget where you are running mesheryctl)?

1 Like

@Philip-21 is this was the crux of your issue, please mark it as the Solution. If not, let me know what trouble it is that you’re still experiencing.

@Philip-21 what lee suggested helped? if yes, please mark it as the solution and don’t hesitate to ask for help again.

Sorry for the late response , i tried it again it gave me the same error , but i was able to access my index.yml on my browser it contained the same items as the index.yml you sent . I also checked the config file in my .meshery directory , these were the configurations i found
> contexts:
> * local:*
> * endpoint: http://localhost:9081*
> * token: default*
> * platform: kubernetes*
> * components:*
> * - meshery-app-mesh*
> * - meshery-istio*
> * - meshery-linkerd*
> * - meshery-consul*
> * - meshery-nsm*
> * - meshery-kuma*
> * - meshery-osm*
> * - meshery-traefik-mesh*
> * - meshery-nginx-sm*
> * - meshery-cilium*
> * channel: stable*
> * version: latest*
> * provider: Meshery*
> current-context: local
> tokens:
> * - name: default*
> * location: auth.json*
It seems maybe its my network connection ,
Because these were the steps i followed ,

  • i had my docker desktop running and i logged in successfully on the meshery extension
  • i ran minikube on my command line to start a cluster
  • i ran mesheryctl system start
    still i got the same error message. But i noticed from the logs below ,I feel it seems to be a network connection problem from my part
    looks like “Meshery Chart | Meshery” is not a valid chart repository or cannot be reached: read tcp 192.168.0.101:63200->185.199.111.153:443: wsarecv: An established connection was aborted by the software in your host machine.
    Maybe someone else can try running it on their windows machine .

@Philip-21 try upgrading your version of mesheryctl.

@Lee it upgraded successfully but when i ran mesheryctl system start , it gave this message
Starting Meshery…
⢿ Deploying Meshery on KubernetesError: failed to start Meshery
See mesheryctl-system | Meshery for usage details
: could not install meshery server: Kubernetes cluster unreachable: Get “https://127.0.0.1:53990/version”: x509: certificate signed by unknown authority
could not install meshery-operator: Kubernetes cluster unreachable: Get “https://127.0.0.1:53990/version”: x509: certificate signed by unknown authority
i also ran > mesheryctl --config "C:\Users\USER.kube\config"
to configure mesheryctl whilst having minikube, mesheryctl and kubectl being updated
but it still gives the same error message . I have been on it for hours trying to figure things out :disappointed:

@Philip-21 you might try the following in your kubeconfig. Under cluster: for your minikube cluster:

  1. Remove the certificate-authority-data entry.
  2. Add an entry for insecure-skip-tls-verify: true.

Try mesheryctl system start, mesheryctl system dashboard.

mesheryctl system check --preflight is also fairly handy.

If these don’t get you there, you can run mesheryctl system config minikube.

Yay it worked @Lee :smiley:, thanks so much these options really gave me an idea on how to solve it , i tried removing the certificate-authority-data entry but it didnt work so i decided to add the minikube token to the certificate-authority-data entry,
I ran the command
kubectl config view --raw --minify --flatten -o jsonpath=‘{.clusters[].cluster.certificate-authority-data}’ to get the certificate authority for minikube , so mesheryctl is running and its finally deployed on kuberentes.

But noticed something @Lee
when mesheryctl is running i am redirected to the page http://localhost:31241/, but i get the message that says site cannot be reached. and again ,

when i run mesheryctl system login it gives this message
*authentication failed: Unable to reach Meshery server at http://localhost:31241. Verify your environment's readiness for a Meshery deployment by running mesheryctl system check.*

on running mesheryctl system check evrything seemed fine

Docker

✓ Docker is running
✓ docker-compose is available

Kubernetes API

✓ can initialize Kubernetes client
✓ can query the Kubernetes API

Kubernetes Version

✓ running the minimum Kubernetes version
✓ running the minimum kubectl version

Meshery Version

!! failed to check Meshery Server version. try starting Meshery with mesheryctl system start
✓ CLI is up-to-date (stable-v0.6.108)

I am only able to authenticate successfully on the meshery docker extension

In these instances, what does mesheryctl system dashboard return?

Sorry for the late reply @Lee
mesheryctl system dashboard
Opening Meshery (http://localhost:31241) in browser.
It opens my browser and shows site can’t be reached running on http://localhost:31241/

Confirm that Meshery is running mesheryctl system status. Confirm that Meshery Server service is exposed external to your cluster.

here it is


PS C:\Users\USER> mesheryctl system status
NAME                    READY   STATUS  RESTARTS        AGE
meshery-app             1/1     Running 1               198h33m24s
meshery                 0/0     Running 0               198h33m24s
meshery-broker          2/2     Running 3               186h2m0s
meshery-cilium          0/0     Running 2               198h33m24s
meshery-consul          0/0     Running 1               198h33m24s
meshery-istio           1/1     Running 3               198h33m24s
meshery-kuma            0/0     Running 2               198h33m24s
meshery-linkerd         0/0     Running 1               198h33m24s
meshery-meshsync        0/0     Pending 0               186h2m0s
meshery-nginx           1/1     Running 0               198h33m24s
meshery-nsm             0/0     Running 1               198h33m24s
meshery-operator        0/0     Running 1               198h33m13s
meshery-osm             0/0     Running 1               198h33m24s
meshery-traefik         0/0     Running 0               198h33m24s

Meshery Server isn’t running.